Author Topic: "no lens attached" message on Dynax 5d  (Read 1665 times)

0 Members and 1 Guest are viewing this topic.

Offline themannsindorset

  • Enthusiast
  • *
  • Posts: 3
"no lens attached" message on Dynax 5d
« on: September 20, 2011, 05:42:44 PM »
About six months ago, I started getting “no lens attached” messages with the af 18-70 f3.5 zoom lens supplied with my Dynax 5d. After a bit I came to the conclusion that because my 100-200 zoom and my ancient f1.7 prime lens were OK that the 18-70 was faulty. So I purchased a new Sigma 17-70 f2.8 DC macro lens. I made about 600 exposures with this new lens until last weekend.   I had just taken about thirty shots with the 100-200 when I switched back to the Sigma and started getting this message. I faffed around a bit as one does and the Dynax + Sigma worked every now and then but not reliably. So I switch back to the 100-200 and that Dynax lens combination also started acting up.
I went home and had a play and discovered that if I twisted the 100-200  then it behaved. AH I said, I may be on to something but it was not to be.
I am now in the position where with the prime f1.7 the Dynax works beautifully every time. The Dynax with the 100-200 works if it feels like it and the Dynax with the new Sigma will not work at all. I am very frustrated as I can not pick up a pattern. The Dynax is a nice camera, has served me well and I don't want to lose it.
I have looked at many forums on the problem and have carried out all the various suggestions such as:

Clean the contacts..They are now the cleanest contacts on the planet but still no joy. Nor are they bent or misshapen.

I activated the “No lens shutter lock feature. No difference.

Made sure that camera was turned off before switching lens.

All three lenses work well on a friends Sony so the body has to be at fault although why my F1.7 still works mystifies me.

Has anybody out there had the same experiences as me? Please get in touch.  I once fixed an electronic problem on a device (I forget what it was) by freezing the unit in a deep freeze so that the on-board battery “forgot” its data. It worked like dream but Id'e rather not do that to my Dynax. Help Please. Peter. Wimborne. Dorset. UK

Offline Gordon McGeachie

  • Friend of DynaxDigital
  • *****
  • Posts: 4427
  • Gender: Male
    • http://www.flickr.com/photos/35699306@N04/
Re: "no lens attached" message on Dynax 5d
« Reply #1 on: September 20, 2011, 05:46:05 PM »
you could try cleaning the contacts in the camera body..............
A700, VG-C70AM, Sony 50mm f1.4,SAL1870, Sony 70-300mm f4.5-5.6 G SSM, A350,A550,3600HSD, Minolta 135, 500 Reflex, Sigma 10-20,  Tamron 17-50mm f2.8 XR Di-II LD ASP IF, Sigma 400, Tamron 90, ,Nissin Di866 MKII,Interfit 150w 2 head kit, Giottos MTL9351B/MH5011
My flickr site is here http://www.flickr.com/photos/35699306@N04/