Author Topic: 5600 hsd broken  (Read 1265 times)

0 Members and 1 Guest are viewing this topic.

Offline steve

  • Senior Member
  • ****
  • Posts: 914
5600 hsd broken
« on: May 04, 2009, 08:36:35 AM »
Hi
Done another wedding on saturday and some how managed to snap off a contact on the flash shoe good job i had a cord to connect gun off camera and shot pics holding gun in air with left hand.Took me a while to figure out why it wouldnt work properly lol. Have two hundred pics to edit today.

  Regards Steve

Offline tpe

  • Past Moderator
  • Friend of DynaxDigital
  • *****
  • Posts: 3842
  • Gender: Male
  • tpe, aka tim
    • Scientific reference pictures and other stuf
Re: 5600 hsd broken
« Reply #1 on: May 04, 2009, 09:10:38 AM »
Which contact do you mean? If it is the hotshoe foot then you can use one of the ones from any of the older ttl flashes that do not support adi. You can also order it directly from sony. It takes about half an hour to replace but can be a little awkward as the leads inside and springs are a bit small and can break easily.

Tim

Offline winjeel

  • Past Moderator
  • Friend of DynaxDigital
  • *****
  • Posts: 5413
  • Gender: Male
  • Gelight
    • japanesephotos
    • JapanesePhotos
    • JapanesePhotos.Asia
Re: 5600 hsd broken
« Reply #2 on: May 04, 2009, 09:20:19 AM »
Ouuwww That must have been annoying. You're able to fix it, right?
JapanesePhotos.Asia; Some basic photographic how to's.
Sony the200, Minolta 28mm 2.8, 50mm 1.4, 70-300mm Gregarious, 100mm 2.8 macro.